summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPixel <Pixel>2001-11-26 23:11:40 +0000
committerPixel <Pixel>2001-11-26 23:11:40 +0000
commit3baa9d168c02a8734b95d1cc467601b6aaf2f6e4 (patch)
tree6c254e9d75dee5a1e305283788fea3d3fff2a445 /configure.in
parent3aa63fcbddbce8762ad0f3f54d90ad985c0f9c41 (diff)
Big job here. Many bugs out. Hurray!!
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 040a095..7b08e37 100644
--- a/configure.in
+++ b/configure.in
@@ -64,6 +64,7 @@ AC_CHECK_HEADERS(alloca.h errno.h netdb.h netinet/in.h sys/socket.h stddef.h)
AC_HEADER_SYS_WAIT
AC_STRUCT_TM
AC_HEADER_TIME
+AC_CHECK_HEADERS([sys/time.h])
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -75,13 +76,14 @@ AC_TYPE_SIGNAL
dnl Checks for library functions.
AC_FUNC_ALLOCA
AC_FUNC_MMAP
-AC_CHECK_FUNCS(getcwd getwd putenv strdup memmove memset)
+AC_CHECK_FUNCS(getcwd getwd putenv strdup memmove memset select poll)
AC_CHECK_FUNCS(strerror strrchr strstr mempcpy nl_langinfo strcspn)
AC_SEARCH_LIBS(socket,socket)
AC_SEARCH_LIBS(gethostbyname,nsl)
AC_FUNC_FORK
AC_FUNC_MALLOC
AC_FUNC_VPRINTF
+AC_FUNC_STRFTIME
AC_PATH_PROG(gmakepath, gmake)
AC_PATH_PROG(unamepath, uname)