summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7b220ac..9eccff9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -100,7 +100,7 @@ if test "$with_gmp" != "no"; then
fi])
found_gmp=no
- AC_CHECK_HEADER(gmp.h,
+ AC_CHECK_HEADER(gmpxx.h,
[AC_CHECK_LIB(gmp, mpz_init,
[GMP_LIBS="-lgmp -lm"; found_gmp=yes],
[AC_CHECK_LIB(gmp, __gmpz_init,
@@ -110,8 +110,8 @@ if test "$with_gmp" != "no"; then
AC_DEFINE([HAVE_GMP], 1, [Have the GMP library])
LIBS="$LIBS $GMP_LIBS"
AC_CHECK_FUNC(__gmp_randinit, AC_DEFINE([HAVE_GMP_RANDINIT], 1, [Have the RandInit function]))
- elif test "$with_gmp" != "no"; then
- AC_MSG_ERROR([Can't find GMP (--without-gmp for cut-down non-GMP build)])
+# elif test "$with_gmp" != "no"; then
+# AC_MSG_ERROR([Can't find GMP (--without-gmp for cut-down non-GMP build)])
fi
fi
AC_SUBST(GMP_LIBS)