summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 40 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 96caac4..6f70efc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,32 +60,33 @@ AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify getcwd gethostbyname m
AC_SEARCH_LIBS(socket, socket)
AC_SEARCH_LIBS(gethostbyname, nsl)
-AC_SEARCH_LIBS(deflate, z)
-
-if test x$ac_cv_search_deflate != xno ; then
- OLDCPPFLAGS=$CPPFLAGS
- CPPFLAGS="-Werror"
- AC_CACHE_CHECK([for well defined gzwrite in zlib.h], ac_cv_wd_gzwrite,
- AC_COMPILE_IFELSE(
- [AC_LANG_PROGRAM(
- [[#include <zlib.h>]],
- [[const char * buf = "Poide"; gzwrite(NULL, buf, 10);]]
- )],
- [AC_DEFINE([HAVE_WD_ZLIB], 1, [Have a well structured ZLIB])
- ac_cv_wd_gzwrite="yes"],[ac_cv_wd_gzwrite="no"
- ])
- )
- CPPFLAGS=$OLDCPPFLAGS
-else
- AC_MSG_ERROR([no zlib found in the system.])
-fi
-
-if test x$ac_cv_wd_gzwrite != xyes ; then
- AC_MSG_WARN([You have a broken zconf.h.]
- [You should patch this using]
- [the zconf.h-patch file.]
- [Enabling workaround.])
-fi
+#AC_SEARCH_LIBS(deflate, z)
+#
+#if test x$ac_cv_search_deflate != xno ; then
+# OLDCPPFLAGS=$CPPFLAGS
+# CPPFLAGS="-Werror"
+# AC_CACHE_CHECK([for well defined gzwrite in zlib.h], ac_cv_wd_gzwrite,
+# AC_COMPILE_IFELSE(
+# [AC_LANG_PROGRAM(
+# [[#include <zlib.h>]],
+# [[const char * buf = "Poide"; gzwrite(NULL, buf, 10);]]
+# )],
+# [AC_DEFINE([HAVE_WD_ZLIB], 1, [Have a well structured ZLIB])
+# ac_cv_wd_gzwrite="yes"],[ac_cv_wd_gzwrite="no"
+# ])
+# )
+# CPPFLAGS=$OLDCPPFLAGS
+#else
+# AC_MSG_ERROR([no zlib found in the system.])
+#fi
+#
+#if test x$ac_cv_wd_gzwrite != xyes ; then
+# AC_MSG_WARN([You have a broken zconf.h.]
+# [You should patch this using]
+# [the zconf.h-patch file.]
+# [Enabling workaround.])
+#fi
+AC_DEFINE([HAVE_WD_ZLIB], 1, [Have a well structured ZLIB])
GMP_LIBS="-lm"
AC_LANG_PUSH(C++)
@@ -127,6 +128,19 @@ AC_DEFINE([HOOK_STDS], 1, [Hook the standard input/outputs])
AC_CHECK_FUNCS(gethostbyname)
AC_CHECK_FUNCS(regcomp)
AC_CHECK_FUNCS(socket)
+AC_CHECK_FUNCS([atexit])
+AC_CHECK_FUNCS([floor])
+AC_CHECK_FUNCS([memchr])
+AC_CHECK_FUNCS([pow])
+AC_CHECK_FUNCS([sqrt])
+AC_CHECK_FUNCS([strpbrk])
+AC_CHECK_FUNCS([strtol])
+AC_CHECK_TYPES([ptrdiff_t])
+AC_FUNC_ERROR_AT_LINE
+AC_FUNC_MEMCMP
+AC_FUNC_MKTIME
+AC_FUNC_STRCOLL
+AC_FUNC_STRTOD
AC_PATH_PROG(gmakepath, gmake)
AC_PATH_PROG(unamepath, uname)