summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ccdf018..5035d7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,7 +61,6 @@ AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify getcwd gethostbyname m
AC_SEARCH_LIBS(socket, socket)
AC_SEARCH_LIBS(gethostbyname, nsl)
AC_SEARCH_LIBS(deflate, z)
-AC_SEARCH_LIBS(EF_Print, efence)
if test x$ac_cv_search_deflate != xno ; then
OLDCPPFLAGS=$CPPFLAGS
@@ -103,11 +102,15 @@ else
system=`$unamepath -s`
AC_MSG_RESULT($system)
fi
-
+
AC_ARG_ENABLE([debug],
[ --enable-debug enable verbose debugging],
AC_DEFINE(DEBUG, 1, [Enable verbose debugging]))
-
+
+AC_ARG_ENABLE([efence],
+ [ --enable-efence enable compiling with electic-fence],
+ AC_SEARCH_LIBS(EF_Print, efence))
+
AC_CONFIG_FILES([baltisot-config
Makefile
doc/Makefile