summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b1c95d1..cb59b1b 100644
--- a/configure.in
+++ b/configure.in
@@ -36,6 +36,7 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_CANONICAL_HOST
AM_PROG_LIBTOOL
+AC_PROG_YACC
dnl Setting up environnement.
ALL_LINGUAS="fr"
@@ -57,7 +58,7 @@ fi
dnl Checks for classical header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS(libintl.h fcntl.h limits.h malloc.h strings.h unistd.h)
+AC_CHECK_HEADERS(libintl.h fcntl.h limits.h malloc.h strings.h unistd.h langinfo.h)
AC_CHECK_HEADERS(alloca.h errno.h netdb.h netinet/in.h sys/socket.h stddef.h)
AC_HEADER_SYS_WAIT
AC_STRUCT_TM
@@ -72,7 +73,7 @@ dnl Checks for library functions.
AC_FUNC_ALLOCA
AC_FUNC_MMAP
AC_CHECK_FUNCS(getcwd getwd putenv strdup memmove memset)
-AC_CHECK_FUNCS(strerror strrchr strstr mempcpy)
+AC_CHECK_FUNCS(strerror strrchr strstr mempcpy nl_langinfo strcspn)
AC_SEARCH_LIBS(socket,socket)
AC_SEARCH_LIBS(gethostbyname,nsl)
AC_FUNC_FORK