summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in152
1 files changed, 0 insertions, 152 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 15d876b..0000000
--- a/configure.in
+++ /dev/null
@@ -1,152 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(src/Main.cc)
-
-dnl Creating versions info.
-
-Baltisot_MAJOR_VERSION=0
-Baltisot_MINOR_VERSION=1
-Baltisot_MICRO_VERSION=0
-Baltisot_VERSION=$Baltisot_MAJOR_VERSION.$Baltisot_MINOR_VERSION.$Baltisot_MICRO_VERSION
-
-dnl set version info for Baltisot.so to package rev - $MAJOR . $MINOR : $MICRO
-Baltisot_VERSION_INFO=$Baltisot_MAJOR_VERSION.$Baltisot_MINOR_VERSION.$Baltisot_MICRO_VERSION
-
-AC_SUBST(Baltisot_MAJOR_VERSION)
-AC_SUBST(Baltisot_MINOR_VERSION)
-AC_SUBST(Baltisot_MICRO_VERSION)
-AC_SUBST(Baltisot_VERSION)
-AC_SUBST(Baltisot_VERSION_INFO)
-
-VERSION=$Baltisot_VERSION
-PACKAGE=Baltisot
-
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
-
-AM_CONFIG_HEADER(config.h)
-
-AM_MAINTAINER_MODE
-
-dnl Checks for classical programs.
-AC_PROG_CXX
-AC_PROG_AWK
-AC_PROG_CC
-AC_PROG_CPP
-AC_PROG_INSTALL
-AC_PROG_LN_S
-AC_PROG_MAKE_SET
-AC_CANONICAL_HOST
-AM_PROG_LIBTOOL
-AC_PROG_YACC
-AM_PROG_GCJ
-
-dnl Setting up environnement.
-ALL_LINGUAS="fr"
-AM_GNU_GETTEXT
-if test x$USE_INCLUDED_LIBINTL = xyes; then
- LINK_SRC="$LINK_SRC intl/libgettext.h"
- LINK_DST="$LINK_DST include/libintl.h"
-fi
-test "$MSGFMT" = "no" && MSGFMT ="$missing_dir/missing msgfmt"
-test "$GMSGFMT" = "no" && GMSGFMT ="$missing_dir/missing msgfmt"
-test "$XGETTEXT" = ":" && XGETTEXT="$missing_dir/missing xgettext"
-
-if test x$gt_cv_func_gettext_libintl = xyes; then
- case "$LIBS" in
- *-lintl*) ;;
- *) LIBS="$LIBS -lintl";;
- esac
-fi
-
-dnl Checks for classical header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS(libintl.h fcntl.h limits.h malloc.h strings.h unistd.h langinfo.h)
-AC_CHECK_HEADERS(alloca.h errno.h netdb.h netinet/in.h sys/socket.h stddef.h)
-AC_HEADER_SYS_WAIT
-AC_STRUCT_TM
-AC_HEADER_TIME
-AC_CHECK_HEADERS([sys/time.h])
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_C_INLINE
-AC_TYPE_SIZE_T
-AC_C_BIGENDIAN
-AC_TYPE_SIGNAL
-
-dnl Checks for library functions.
-AC_FUNC_ALLOCA
-AC_FUNC_MMAP
-AC_CHECK_FUNCS(getcwd getwd putenv strdup memmove memset select poll)
-AC_CHECK_FUNCS(strerror strrchr strstr mempcpy nl_langinfo strcspn)
-AC_SEARCH_LIBS(socket,socket)
-AC_SEARCH_LIBS(gethostbyname,nsl)
-AC_SEARCH_LIBS(deflate,z)
-if test x$ac_cv_search_deflate != xno ; then
- OLDCPPFLAGS=$CPPFLAGS
- CPPFLAGS="-Werror"
- AC_CACHE_CHECK([for well defined gzwrite in zlib.h], ac_cv_wd_gzwrite,
- AC_TRY_COMPILE(
- [#include <zlib.h>],
- [const char * buf = "Poide"; gzwrite(NULL, buf, 10);],
- [AC_DEFINE(HAVE_WD_ZLIB)
- ac_cv_wd_gzwrite="yes"],
- [ac_cv_wd_gzwrite="no"]
- AC_ERROR([You have a broken zconf.h and compiler pair. You]
- [should patch this using the zconf.h-patch file.])
- )
- )
- CPPFLAGS=$OLDCPPFLAGS
-else
- AC_ERROR([This library needs the zlib library. You can find]
- [it at the url: http://www.zlib.org])
-fi
-
-AC_FUNC_FORK
-AC_FUNC_MALLOC
-AC_FUNC_VPRINTF
-AC_FUNC_STRFTIME
-AC_CHECK_FUNCS(gethostbyname)
-AC_CHECK_FUNCS(regcomp)
-AC_CHECK_FUNCS(socket)
-
-AC_PATH_PROG(gmakepath, gmake)
-AC_PATH_PROG(unamepath, uname)
-if test "x$unamepath" = x; then
- system="unknown"
-else
- AC_MSG_CHECKING(system type)
- system=`$unamepath -s`
- AC_MSG_RESULT($system)
-fi
-
-AC_SUBST(bindir)
-
-AC_OUTPUT([
- Makefile
- include/Makefile
- lib/Makefile
- doc/Makefile
- src/Makefile
- src/datas/Makefile
- po/Makefile.in
- po/Makefile
- intl/Makefile
- m4/Makefile
-])
-
-echo
-echo \-\-\= $PACKAGE $VERSION \=\-\-
-echo
-
-echo Build System .................... : $system
-echo Build Host ...................... : $host
-echo Install Prefix .................. : $prefix
-echo
-
-if test _"$gmakepath" = _; then
- echo configure complete, now type \'make\'
-else
- echo configure complete, now type \'gmake\'
-fi
-
-echo