summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..581d51f
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,18 @@
+AUTOMAKE_OPTIONS = foreign no-dependencies
+
+VERSION_INFO = 1:0
+
+EXTRA_DIST = LICENSE libev.m4 autogen.sh \
+ ev.h ev_vars.h ev_wrap.h event_compat.h ev++.h event.h \
+ ev_epoll.c ev_select.c ev_poll.c ev_kqueue.c ev_port.c ev_win32.c \
+ ev.3 ev.pod
+
+man_MANS = ev.3
+
+include_HEADERS = ev.h event_compat.h ev++.h event.h
+
+lib_LTLIBRARIES = libev.la
+
+libev_la_SOURCES = ev.c event.c
+libev_la_LDFLAGS = -version-info $(VERSION_INFO)
+