summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorroot <root>2005-03-03 17:06:44 +0000
committerroot <root>2005-03-03 17:06:44 +0000
commit4ea2a2d5858c25172e9b30c8bdae71f33785dde2 (patch)
tree838e8a79206cbff3b211713f758b66023b526819 /configure.ac
parent328707ad20d43aac1d7d9cde611d7581dc25d793 (diff)
*** empty log message ***
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c289d82
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,24 @@
+AC_INIT
+AC_CONFIG_SRCDIR([lzfP.h])
+
+AC_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_INSTALL
+AC_HEADER_STDC
+
+AC_CHECK_SIZEOF(short, 2)
+AC_CHECK_SIZEOF(int, 4)
+AC_CHECK_SIZEOF(long, 4)
+
+AC_C_CONST
+
+if test "$GCC" = yes; then
+ CFLAGS="$CFLAGS -O3 -funroll-all-loops"
+else
+ AC_MSG_RESULT(no gcc)
+fi
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT