summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorroot <root>2002-06-09 22:41:34 +0000
committerroot <root>2002-06-09 22:41:34 +0000
commitdb8367fa234d20d6e8e07901398fd45e23058d7b (patch)
treec0c635ca63d515c33e69cb051bb56ed565f4c2ca /configure.in
*** empty log message ***
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..33b5921
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,22 @@
+AC_INIT(lzfP.h)
+
+AC_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_INSTALL
+AC_HEADER_STDC
+
+AC_CHECK_SIZEOF(short, 2)
+AC_CHECK_SIZEOF(int, 4)
+AC_CHECK_SIZEOF(long, 4)
+
+AC_C_CONST
+
+if test "$GCC" = yes; then
+ CFLAGS="$CFLAGS -O2 -funroll-all-loops"
+else
+ AC_MSG_RESULT(no gcc)
+fi
+
+AC_OUTPUT(Makefile)