summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c289d82..830eb9d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,6 +3,8 @@ AC_CONFIG_SRCDIR([lzfP.h])
AC_CONFIG_HEADER(config.h)
+AC_GNU_SOURCE
+AC_SYS_LARGEFILE
AC_PROG_CC
AC_PROG_RANLIB
AC_PROG_INSTALL
@@ -13,6 +15,9 @@ AC_CHECK_SIZEOF(int, 4)
AC_CHECK_SIZEOF(long, 4)
AC_C_CONST
+AC_C_INLINE
+AC_CHECK_HEADERS(getopt.h)
+AC_CHECK_FUNCS(getopt_long)
if test "$GCC" = yes; then
CFLAGS="$CFLAGS -O3 -funroll-all-loops"