summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbje <bje>1998-10-03 04:28:32 +0000
committerbje <bje>1998-10-03 04:28:32 +0000
commit28706c21dca90eac5d555051ae464d6d292d1a7e (patch)
tree3416351c10d7ae608227d23027143cacd57725dc /configure.in
parent6387bf1151eb5d61e4ce2fca165b013dcc5e29fc (diff)
1998-10-03 Ben Elliston <bje@cygnus.com>
* configure.in: Test for the `_stdcall' keyword. Define `STDCALL' to `_stdcall' if we have it, null otherwise. * configure: Regenerate. * acconfig.h (STDCALL): New define.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0896edb..7bd1784 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,13 @@ then
AC_DEFINE(HAVE_SIGSET_T)
fi
fi
+AC_CACHE_CHECK(for _stdcall keyword, p32_cv_stdcall,
+ AC_TRY_COMPILE( ,[int _stdcall foo();],
+ p32_cv_stdcall=yes, p32_cv_stdcall=no))
+
+if test x$p32_cv_stdcall = xyes ; then
+ AC_DEFINE(STDCALL, _stdcall)
+fi
AC_CHECK_HEADERS(windows.h,,AC_MSG_WARN([Target system must be Win32]))
AC_OUTPUT(Makefile)