summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbje <bje>1998-09-13 04:38:15 +0000
committerbje <bje>1998-09-13 04:38:15 +0000
commit8b32771829b8908338c33c9ea1e3bed51e5232eb (patch)
tree5fb4931acabcc47ce815fa93363358b958f74058 /configure.in
parent1079e9e1d036a9a5d44ecf4c99ff42eb29366db3 (diff)
1998-09-13 Ben Elliston <bje@cygnus.com>
* configure.in: Test for required system features. * configure: Generate. * acconfig.h: New file. * config.h.in: Generate. * Makefile.in: Renamed from Makefile. * COPYING: Import from a recent GNU package. * config.guess: Likewise. * config.sub: Likewise. * install-sh: Likewise. * Makefile: Remove. * config.h: Likewise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..0896edb
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,20 @@
+dnl Process this file with autoconf to produce a configure script.
+
+AC_INIT(pthread.h)
+AC_CANONICAL_HOST
+AC_CONFIG_HEADER(config.h)
+AC_PROG_CC
+AC_CHECK_HEADERS([signal.h],signal_h=yes,)
+if test x$signal_h = xyes
+then
+ AC_CACHE_CHECK([for sigset_t], p32_cv_sigset_t,
+ AC_TRY_COMPILE([#include <signal.h>], [sigset_t x;],
+ p32_cv_sigset_t=yes, p32_cv_sigset_t=no))
+
+ if test x$p32_cv_sigset_t = xyes ; then
+ AC_DEFINE(HAVE_SIGSET_T)
+ fi
+fi
+
+AC_CHECK_HEADERS(windows.h,,AC_MSG_WARN([Target system must be Win32]))
+AC_OUTPUT(Makefile)