summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorPixel <Pixel>2001-09-20 23:27:01 +0000
committerPixel <Pixel>2001-09-20 23:27:01 +0000
commit8346d0774d2d1e076038db27f65f1d082a460f16 (patch)
tree132f84cf1ef45d5006a2b1d52d4d40b1e8e51abc /lib/Makefile.am
Initial revision
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..5149387
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,12 @@
+localedir = $(datadir)/locale
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+AM_CFLAGS = -O3 -Wall -Wstrict-prototypes $(CFLAGS)
+AM_CXXFLAGS = -O3 -Wall -Wstrict-prototypes $(CXXFLAGS)
+INCLUDES = -I. -I.. -I$(includedir) -I../include
+lib_LTLIBRARIES = libClasses.la
+
+libClasses_la_SOURCES = Exceptions.cc Handle.cc Output.cc String.cc\
+ Socket.cc Input.cc HttpServ.cc Variables.cc Action.cc Menu.cc Message.cc\
+ Form.cc Confirm.cc Table.cc checkargs.c datecalc.c
+
+libClasses_la_LDFLAGS = -version-info $(Classes_VERSION_INFO)