summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorPixel <>2001-04-15 02:21:56 +0000
committerPixel <>2001-04-15 02:21:56 +0000
commitba6d5b2571acd4010c929901b490bcd836c4ca3c (patch)
tree20c8fa3dedd2aecb6c8448c5f325a8af04875a73 /lib/Makefile.am
parentdff18f36172e0209c5dffefe54ec61185f7a8aba (diff)
Inclusion du simulateur.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index b463138..f6172b3 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -2,10 +2,12 @@ localedir = $(datadir)/locale
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
AM_CFLAGS = -O3 -Wall -Wstrict-prototypes $(CFLAGS)
INCLUDES = -I. -I.. -I$(includedir) -I../include
-lib_LTLIBRARIES = libCompilo.la
+lib_LTLIBRARIES = libCompilo.la libSimul.la
libCompilo_la_SOURCES = assembler.c parser.c meta.c numbers.c hash.c exceptions.c
+libSimul_la_SOURCES = alu.c archi.c exceptions.c fpu.c interne.c memoire.c registre.c
libCompilo_la_LDFLAGS = -version-info $(ProjetArchi_VERSION_INFO)
+libSimul_la_LFDLAGS = -version-info $(ProjetArchi_VERSION_INFO)
-EXTRA_DIST = instructions.txt \ No newline at end of file
+EXTRA_DIST = instructions.txt