summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c2ee92d..6dfdbb3 100644
--- a/configure.in
+++ b/configure.in
@@ -24,6 +24,15 @@ AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
+AC_ARG_WITH(debug,
+[ --with-debug enable debug info],
+[ with_debug=$withval; ],
+[ with_debug=no; ])
+
+if test x$with_debug = xyes; then
+ AC_DEFINE(DEBUG)
+fi
+
dnl Checks for programs.
AC_PROG_CXX
AC_PROG_AWK