summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 0000000..4d66b47
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,11 @@
+localedir = $(datadir)/locale
+DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
+AM_CFLAGS = -O3 -Wall -Wstrict-prototypes $(CFLAGS)
+INCLUDES = -I. -I.. -I$(includedir) -I../include
+lib_LTLIBRARIES = libCompilo.la
+
+libCompilo_la_SOURCES = assembler.c parser.c meta.c numbers.c hash.h
+
+libCompilo_la_LDFLAGS = -version-info $(ProjetArchi_VERSION_INFO)
+
+EXTRA_DIST = instructions.txt \ No newline at end of file