summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorroot <root>2012-02-04 19:09:28 +0000
committerroot <root>2012-02-04 19:09:28 +0000
commitcfc8bb62da40ad66cead6027ec3c4d10e3bb54a5 (patch)
tree929be7d51cf4c3febe6fe83e2b50fab771cc8cfb /configure.ac
parent17a065102d394e99a685c1f65b9fd28bad95ca04 (diff)
*** empty log message ***
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 11 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 5ad67f2..31d0a25 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,3 +1,5 @@
+orig_CFLAGS="$CFLAGS"
+
AC_INIT
AC_CONFIG_SRCDIR([ev_epoll.c])
@@ -5,13 +7,18 @@ AM_INIT_AUTOMAKE(libev,4.11) dnl also update ev.h!
AC_CONFIG_HEADERS([config.h])
AM_MAINTAINER_MODE
-AC_PROG_INSTALL
-AC_PROG_LIBTOOL
+AC_PROG_CC
-if test "x$GCC" = xyes ; then
- CFLAGS="-O3 $CFLAGS"
+dnl Supply default CFLAGS, if not specified
+if test -z "$orig_CFLAGS"; then
+ if test x$GCC = xyes; then
+ CFLAGS="-g -O3"
+ fi
fi
+AC_PROG_INSTALL
+AC_PROG_LIBTOOL
+
m4_include([libev.m4])
AC_CONFIG_FILES([Makefile])