summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpixel <pixel>2002-12-06 18:54:59 +0000
committerpixel <pixel>2002-12-06 18:54:59 +0000
commit70ab3da408f5939fbfec4237e87f503ae82b2179 (patch)
treecc2e867aa3d57fe7bead0e9fbf1b1cba9008eac5 /configure.ac
parent4e771e092cfb1d8c2850205285ba480e7376a186 (diff)
Commit of the day.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b8f4e62..5983291 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,11 +22,26 @@ AM_PROG_LIBTOOL
# Checks for libraries.
AC_CHECK_LIB([c], [printf])
+AM_PATH_SDL(1.2.0, , AC_MSG_ERROR([SDL needed.]))
+AM_PATH_BALTISOT(, AC_MSG_ERROR([Baltisot needed.]))
+AC_SEARCH_LIBS(glVertex3d, GL, , [
+ unset ac_cv_search_glVertex3d
+ AC_MSG_NOTICE([OpenGL not found in standard path. Looking in /usr/X11R6/lib])
+ LDFLAGS="-L/usr/X11R6/lib $LDFLAGS"
+ AC_SEARCH_LIBS(glVertex3d, GL, , AC_MSG_ERROR([can't find OpenGL]))
+])
+AC_SEARCH_LIBS(gluPerspective, GLU, , [
+ unset ac_cv_search_gluPerspective
+ AC_MSG_NOTICE([GLU not found in standard path. Looking in /usr/X11R6/lib])
+ LDFLAGS="-L/usr/X11R6/lib $LDFLAGS"
+ AC_SEARCH_LIBS(gluPerspective, GLU, , AC_MSG_ERROR([can't find GLU]))
+])
# Checks for header files.
AC_FUNC_ALLOCA
AC_HEADER_STDC
AC_CHECK_HEADERS([argz.h fcntl.h inttypes.h langinfo.h libintl.h limits.h locale.h malloc.h stddef.h stdint.h stdio_ext.h stdlib.h string.h strings.h sys/param.h unistd.h])
+AC_HEADER_STDBOOL
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -41,7 +56,8 @@ ALL_LINGUAS="fr"
AC_FUNC_MALLOC
AC_FUNC_MMAP
AC_FUNC_REALLOC
-AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify getcwd mempcpy munmap nl_langinfo setlocale stpcpy strcasecmp strchr strcspn strdup strstr strtoul])
+AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify getcwd mempcpy munmap nl_langinfo setlocale stpcpy strcasecmp strchr strcspn strdup strstr strtoul atexit])
+
AC_PATH_PROG(gmakepath, gmake)
AC_PATH_PROG(unamepath, uname)