summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 117d31e..f038c06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,9 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.56)
-PACKAGE="mogltk"
-VERSION="0.0.1"
AC_INIT([mogltk], [0.0.1], [pixel@nobis-crew.org])
+AM_INIT_AUTOMAKE(mogltk, 0.0.1)
AC_CONFIG_SRCDIR([intl/bindtextdom.c])
AM_CONFIG_HEADER(config.h)
@@ -17,10 +16,10 @@ AC_PROG_LN_S
AC_PROG_MAKE_SET
AC_PROG_RANLIB
AC_PROG_YACC
+AM_PROG_LIBTOOL
# Checks for libraries.
-# FIXME: Replace `main' with a function in `-lc':
-AC_CHECK_LIB([c], [main])
+AC_CHECK_LIB([c], [printf])
# Checks for header files.
AC_FUNC_ALLOCA