summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 46 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab22663..117d31e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,2 +1,47 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
-AC_OUTPUT([])
+AC_PREREQ(2.56)
+PACKAGE="mogltk"
+VERSION="0.0.1"
+AC_INIT([mogltk], [0.0.1], [pixel@nobis-crew.org])
+AC_CONFIG_SRCDIR([intl/bindtextdom.c])
+AM_CONFIG_HEADER(config.h)
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+AC_PROG_YACC
+
+# Checks for libraries.
+# FIXME: Replace `main' with a function in `-lc':
+AC_CHECK_LIB([c], [main])
+
+# Checks for header files.
+AC_FUNC_ALLOCA
+AC_HEADER_STDC
+AC_CHECK_HEADERS([argz.h fcntl.h inttypes.h langinfo.h libintl.h limits.h locale.h malloc.h stddef.h stdint.h stdio_ext.h stdlib.h string.h strings.h sys/param.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_C_INLINE
+AC_TYPE_SIZE_T
+AC_C_VOLATILE
+
+# Checks for library functions.
+AM_GNU_GETTEXT
+ALL_LINGUAS="fr"
+AC_FUNC_MALLOC
+AC_FUNC_MMAP
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify getcwd mempcpy munmap nl_langinfo setlocale stpcpy strcasecmp strchr strcspn strdup strstr strtoul])
+
+AC_CONFIG_FILES([Makefile
+ intl/Makefile
+ m4/Makefile])
+AC_OUTPUT