summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8e5f43e..30f7436 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,8 +39,6 @@ AC_SEARCH_LIBS(gluPerspective, GLU, , [
AC_SEARCH_LIBS(gluPerspective, GLU, , AC_MSG_ERROR([can't find GLU]))
])
-AC_SEARCH_LIBS(EF_Print, efence)
-
# Checks for header files.
AC_FUNC_ALLOCA
AC_HEADER_STDC
@@ -63,9 +61,17 @@ AC_FUNC_REALLOC
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([__argz_count __argz_next __argz_stringify getcwd mempcpy munmap nl_langinfo setlocale stpcpy strcasecmp strchr strcspn strdup strstr strtoul atexit])
+AC_ARG_ENABLE([debug],
+ [ --enable-debug enable verbose debugging],
+ AC_DEFINE(DEBUG, 1, [Enable verbose debugging]))
+
+AC_ARG_ENABLE([efence],
+ [ --enable-efence enable compiling with electic-fence],
+ AC_SEARCH_LIBS(EF_Print, efence))
AC_PATH_PROG(gmakepath, gmake)
AC_PATH_PROG(unamepath, uname)
+
if test "x$unamepath" = x; then
system="unknown"
else