summaryrefslogtreecommitdiff
path: root/Cpu
diff options
context:
space:
mode:
authorNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-21 03:37:45 +0200
committerNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-21 03:37:45 +0200
commit14d90c9e1171655b864316c9c4aa34033fdd3a45 (patch)
tree3c297e80f774b4a6452331ff840fe6c415875e11 /Cpu
parent8c9c24358cca81cdb15462cb74afc5f173966c79 (diff)
Very first bit towards a Mips/PSX disassembler
Diffstat (limited to 'Cpu')
-rw-r--r--Cpu/Makefile16
-rw-r--r--Cpu/cpu-mips.cpp0
-rw-r--r--Cpu/cpu.cpp0
3 files changed, 16 insertions, 0 deletions
diff --git a/Cpu/Makefile b/Cpu/Makefile
new file mode 100644
index 0000000..87835d6
--- /dev/null
+++ b/Cpu/Makefile
@@ -0,0 +1,16 @@
+TARGET = Cpu.a
+
+SRCS = \
+cpu.cpp \
+cpu-mips.cpp \
+
+SPATH =
+
+CPPFLAGS = -I. -I../Database -I../Database/internals
+
+include ../Makefile.cfg
+
+$(TARGET): $(OBJS)
+ $(AR) $@ $^
+
+-include $(DEPS)
diff --git a/Cpu/cpu-mips.cpp b/Cpu/cpu-mips.cpp
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/Cpu/cpu-mips.cpp
diff --git a/Cpu/cpu.cpp b/Cpu/cpu.cpp
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/Cpu/cpu.cpp