summaryrefslogtreecommitdiff
path: root/Database/Makefile
diff options
context:
space:
mode:
authorNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-20 23:10:31 +0200
committerNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-20 23:10:31 +0200
commit1f7ca9fd3964481318bbaddfb39acc5de8c7d65d (patch)
treef13ae2ddd03c23d81157b86bf9305de36a5ace60 /Database/Makefile
parenteb3bf203a14e81735d6f74467541a6500a3bdf86 (diff)
Basic makefile structure; making the project at least compilable.
Diffstat (limited to 'Database/Makefile')
-rw-r--r--Database/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Database/Makefile b/Database/Makefile
new file mode 100644
index 0000000..4e6b2ff
--- /dev/null
+++ b/Database/Makefile
@@ -0,0 +1,17 @@
+TARGET = Database.a
+
+SRCS = \
+database-internal.cpp \
+database-references.cpp \
+database-segment.cpp \
+
+SPATH = internals
+
+CPPFLAGS = -Iinternals -I.
+
+include ../Makefile.cfg
+
+$(TARGET): $(OBJS)
+ $(AR) $@ $^
+
+-include $(DEPS)