summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-20 23:10:31 +0200
committerNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-20 23:10:31 +0200
commit1f7ca9fd3964481318bbaddfb39acc5de8c7d65d (patch)
treef13ae2ddd03c23d81157b86bf9305de36a5ace60 /Makefile
parenteb3bf203a14e81735d6f74467541a6500a3bdf86 (diff)
Basic makefile structure; making the project at least compilable.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1767149
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+DIRS=externals Utils Database
+
+all: $(DIRS)
+
+clean: clean-dirs
+
+clean-dirs:
+ for i in $(DIRS) ; do $(MAKE) -C $$i clean ; done
+
+.PHONY: $(DIRS)
+
+define DIR_template
+$(1):
+ $$(MAKE) -C $$@
+endef
+
+$(foreach dir, $(DIRS), $(eval $(call DIR_template, $(dir))))