summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..1767149
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,17 @@
+DIRS=externals Utils Database
+
+all: $(DIRS)
+
+clean: clean-dirs
+
+clean-dirs:
+ for i in $(DIRS) ; do $(MAKE) -C $$i clean ; done
+
+.PHONY: $(DIRS)
+
+define DIR_template
+$(1):
+ $$(MAKE) -C $$@
+endef
+
+$(foreach dir, $(DIRS), $(eval $(call DIR_template, $(dir))))