summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-21 02:14:59 +0200
committerNicolas "Pixel" Noble <pixel@nobis-crew.org>2009-09-21 02:14:59 +0200
commit8c9c24358cca81cdb15462cb74afc5f173966c79 (patch)
tree2c3529c863db41eaf78b912405f982c6208825fa /Makefile
parent2fa3e53855dd12c13560dbe7da19eac7b90a3b29 (diff)
Adding doxygen configuration & support.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a072ca4..52af23e 100644
--- a/Makefile
+++ b/Makefile
@@ -2,12 +2,19 @@ DIRS=externals Utils Engine Lua Loader Database
all: $(DIRS)
+doc:
+
clean: clean-dirs
+ rm -rf doc
+
+doc: doxygen.conf
+ make -p doc
+ doxygen doxygen.conf
clean-dirs:
for i in $(DIRS) ; do $(MAKE) -C $$i clean ; done
-.PHONY: $(DIRS)
+.PHONY: $(DIRS) doc clean
define DIR_template
$(1):