summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index a072ca4..52af23e 100644
--- a/Makefile
+++ b/Makefile
@@ -2,12 +2,19 @@ DIRS=externals Utils Engine Lua Loader Database
all: $(DIRS)
+doc:
+
clean: clean-dirs
+ rm -rf doc
+
+doc: doxygen.conf
+ make -p doc
+ doxygen doxygen.conf
clean-dirs:
for i in $(DIRS) ; do $(MAKE) -C $$i clean ; done
-.PHONY: $(DIRS)
+.PHONY: $(DIRS) doc clean
define DIR_template
$(1):